macOS Catalina, quelques précautions à prendre

8
2614
mac os catalina 10.15

Apple pro­pose la nou­velle décli­nai­son de son sys­tème d’ex­ploita­tion macOS Catali­na soit la ver­sion Mac OS X 10.15.

Il s’ag­it d’une mise à jour majeure qui apporte bon nom­bre de nou­veautés et ori­en­ta­tions intéres­santes quant à l’avenir du Sys­tème à la Pomme :

  • Faire tourn­er les appli­ca­tions iPad sur Mac, grâce au pro­jet Cat­a­lyst, par exem­ple Pod­casts et Rap­pels qui sont d’ores-et-déjà intégrées.
  • iTunes laisse place à des appli­ca­tions séparées pour la musique et les vidéos, les pod­casts et la ges­tion des appareils.
  • Pho­tos gagne une nou­velle inter­face plus dynamique.
  • Side­car vous per­met d’u­tilis­er votre iPad comme un écran externe tactile.
  • Temps d’écran, vous per­met de gér­er vos usages numériques, mais aus­si ceux de votre famille…

Comme toute mise à jour ou mise à niveau de macOS, il est impor­tant de pren­dre les pré­cau­tions d’usage pour éviter toute mau­vaise sur­prise… D’au­tant plus que Catali­na ne per­met plus l’u­til­i­sa­tion des appli­ca­tions 32bits, seules les appli­ca­tions 64bits seront désor­mais utilisables.

Accompagnement au passage à macOS Catalina

Ex Cal­i­bra peut vous accom­pa­g­n­er à effectuer cette tran­si­tion vers macOS Catalina :

  • Audit matériel et logi­ciel de votre parc
  • Sauve­g­arde complète
  • Réac­tu­al­i­sa­tion des logi­ciels en ver­sion 64bits
  • Migra­tion de vos données
  • Opti­mi­sa­tion des configurations
  • Tests
  • For­ma­tion à l’u­til­i­sa­tion de macOS Catalina

En cas de besoin urgent de matériel com­pat­i­ble avec macOS Mojave soit Mac OS X 10.14, Ex Cal­i­bra peut tou­jours vous fournir du matériel neuf com­pat­i­ble et instal­lé avec macOS Mojave pour déploy­er les ver­sions logi­cielles qui ne seraient pas encore com­pat­i­bles macOS Catalina.

En tant que spé­cial­iste Apple et expert Mac recon­nu, Ex Cal­i­bra peut vous aider à déploy­er, organ­is­er et main­tenir votre sys­tème d’in­for­ma­tion sous Mac OS en envi­ron­nement Apple unique­ment ou en envi­ron­nement hétérogène, Mac, Win­dows et/ou Linux.

Les précautions à prendre avant de migrer

audit matériel catalina

Audit de compatibilité matériel

macOS Catali­na sera com­pat­i­ble avec la plu­part des mod­èles Mac com­mer­cial­isés en 2012 ou plus tard, et vous pour­rez effectuer la mise à niveau directe­ment à par­tir d’OS X Mav­er­icks ou d’une ver­sion ultérieure.

compatibiité 64bits catalina

Audit de compatibilité logiciels, fin des applications 32bits

Annon­cé aux développeurs en 2018 et intro­duit depuis macOS X 10.14 Mojave, le sys­tème ne peut exé­cuter que des appli­ca­tions dévelop­pées en 64bits donc toutes les anci­ennes appli­ca­tions com­pilées en 32bits sont exclues lors de la mise à jour.

À la fin de cet arti­cle, nous retran­scrivons une liste non exhaus­tive des logi­ciels qui ne fonc­tion­neront pas sur macOS Catalina.

N.B. Cer­tains pilotes matériels sont eux aus­si impactés par l’im­pos­si­bil­ité d’exé­cuter du code 32bits. Les API Sesam-Vitale actuelles ne fonc­tion­nent pas sur macOS Catali­na.

Sauvegarde Catalina

Sauvegarde complète préalable obligatoire

Avant d’installer une mise à jour, il est pri­mor­dial de sauve­g­arder les don­nées de votre Mac.

Stockage nécessaire Catalina

Lien de téléchargement

Si vous utilisez macOS Mojave, choi­sis­sez le menu Pomme  > Préférences Sys­tème, puis cliquez sur Mise à jour de logi­ciels pour accéder à la mise à jour. Si vous utilisez une ver­sion antérieure de macOS, accédez à l’App Store (8,09 Go)

Liste non exhaustives des applications incompatibles macOS Catalina

Adobe Illus­tra­tor CS5
Abobe InDe­sign CS5 & CS6
Apple Aperture
Final Cut Pro X 10.3.4
Motion 5.3.2
Com­pres­sor 4.3.2
Log­ic Pro X 10.3.1
Main­Stage 3.3
iWork ’09: Pages, Keynote & Numbers
Microsoft Excel 2011
Microsoft Pow­er­Point 2011
Microsoft Out­look 2011
Microsoft Word 2011
Call of Duty
Call of Duty 2
Call of Duty 4
Call of Duty Black Ops
Call of Duty Mod­ern War­fare 2
Civ­i­liza­tion IV
Civ­i­liza­tion IV: Colonization
Doom 3
Duke Nukem Forever
Fahrenheit
Home­world Remas­tered Collection
Prey
Quake 4
RAGE
Star Wars: Empire at War
Star Wars: Jedi Academy
Star Wars: Jedi Outcast
Star Wars: The Force Unleashed
Sims 2: Life Stories
Sims 2: Pet Stories
Sims 2: Cast­away Stories
Tomb Raider 2

Liste des applications désinstallées par Apple lors de la mise à jour vers macOS Catalina (235 applications)

10.5 Soft­ware Update et ver­sions antérieures
1Password 2.12.1 et ver­sions antérieures
3D Weath­er Globe / 3D Weath­er Globe Deluxe Edi­tion / 3D Weath­er Globe 2 Screensaver
3ivx 504 et ver­sions antérieures
ADmit­Mac 9.0.1 et ver­sions antérieures
Adobe Cre­ative Cloud 1.0.x et ver­sions antérieures
Adobe Cre­ative Cloud 1.1.x et ver­sions antérieures
AirDis­play 1.6.3 et ver­sions antérieures
AJA 12.2.1 et ver­sions antérieures
AJA Io HD Dri­ver 6.0.3 et ver­sions antérieures
Anti­dote HD 7.2 et ver­sions antérieures
Anti­dote HD 3.1.6 et ver­sions antérieures
Anti­dote RX
App Tamer 2.0.5 et ver­sions antérieures
Apple Con­fig­u­ra­tor 1.9.9 et ver­sions antérieures
Asepsis
AT&T Lap­top Con­nect Card 1.0.4 et ver­sions antérieures
AT&T Lap­top Con­nect Card 1.0.5 et ver­sions antérieures
AT&T Lap­top Con­nect Card 1.10.0 et ver­sions antérieures
Avast! 1.0.1 et ver­sions antérieures
Avast Mac Secu­ri­ty 10.14 et ver­sions antérieures
Avid Core­Au­dio Plu­g­in 12.1.0.x et ver­sions antérieures
Bark 1.1 et ver­sions antérieures
Bark 1.0.1 et ver­sions antérieures
Belkin Router Monitor
Best Youtube Downloader
Billings Pro 1.6.5 et ver­sions antérieures
Box Sync 4.0.6567 et ver­sions antérieures
Cam­ou­flage 2.0 et ver­sions antérieures
Canon UFRII 2.25 et ver­sions antérieures
Canon UFRII 2.35 et ver­sions antérieures
cDock 1.1.3 et ver­sions antérieures
CHUD
Clus­ters 1.7 et ver­sions antérieures
Cos­mo­Pod 4.5.1 et ver­sions antérieures
DAVE 12.0.1 et ver­sions antérieures
Default Fold­er X 4.3.10 et ver­sions antérieures
Disk for iPhone
Dis­playLink 1.9 et ver­sions antérieures
Dis­play­Pad 5 et ver­sions antérieures
Dis­play­Pad 1.4 et ver­sions antérieures
DivX 1.3 et ver­sions antérieures
Dou­bleCom­mand 1.6.9 et ver­sions antérieures
Drop­box 1.1.34 et ver­sions antérieures
eID 4.0.7 et ver­sions antérieures
ESET Cyber Secu­ri­ty 6.0.14 et ver­sions antérieures
Fast­Cut Thresh­old Plu­g­in 1.0 et ver­sions antérieures
Flip4Mac 3.0 et ver­sions antérieures
For­ti­Client 5.4.0.493 et ver­sions antérieures
Find­er­Pop 2.4.9 et ver­sions antérieures
Final Cut Serv­er Pref­er­ence 1.5.2 et ver­sions antérieures
Genieo 2.0 et ver­sions antérieures
Glim­merBlock­er 1.4.12 et ver­sions antérieures
Glims 1.0b34 et ver­sions antérieures
Glims 1.0.42 et ver­sions antérieures
Google Japan­ese IM 1.13.1880 et ver­sions antérieures
GPG Mail 2.5.1 et ver­sions antérieures
Growl 1.2.2 et ver­sions antérieures
Guten­print 5.2.10 et ver­sions antérieures
Hear Plu­g­in 1.0.4 et ver­sions antérieures
Hear Plu­g­in 1.0.5 et ver­sions antérieures
Hear Plu­g­in 1.1.4 et ver­sions antérieures
Instan­tOn 7.2.1 et ver­sions antérieures
iStat Menus 2.9 et ver­sions antérieures
iStat Menus 4.20 et ver­sions antérieures
iStat Menus 5.10 et ver­sions antérieures
iStat Serv­er 2.21 et ver­sions antérieures
Kasper­sky Antivirus 2.2.0d16 et ver­sions antérieures
Kan­box 1.1.2.x et ver­sions antérieures
Kan­box 1.1.1 et ver­sions antérieures
Key­Mag­ic 1.5 et ver­sions antérieures
Kine­meCore 0.5.1 et ver­sions antérieures
LabTech Agent 1.0 et ver­sions antérieures
LaC­ie USB 3.0 Dri­ver 1.0.8 et ver­sions antérieures
launch2net Dri­vers 2.13.0 et ver­sions antérieures
Lazy­Mouse 2.5 et ver­sions antérieures
Lite­coin Tick­er 1.337 et ver­sions antérieures
Lit­tle Snitch 1.2.64 et ver­sions antérieures
Lit­tle Snitch 2.5.3 et ver­sions antérieures
Lit­tle Snitch 3.3 et ver­sions antérieures
Line6 TonePort Dri­ver 4.1.0 et ver­sions antérieures
Log­itech Con­trol Cen­ter 3.9.4 et ver­sions antérieures
M‑Audio Dri­ver 1.10.1 et ver­sions antérieures
M‑Audio Dri­ver 2.3.1 et ver­sions antérieures
Mac­spoofer 1.0 et ver­sions antérieures
Mag­i­can 1.4.8 et ver­sions antérieures
McAfee Inter­net Secu­ri­ty 3.3 et ver­sions antérieures
McAfee Secu­ri­ty 1.0.0d1 et ver­sions antérieures
McAfee VirusS­can 8.6 et ver­sions antérieures
Mou 0.8.7 et ver­sions antérieures
Move Media Player
MyBook RAID Man­ag­er 1.0.1 et ver­sions antérieures
Net Nan­ny 3.1.7 et ver­sions antérieures
Nor­ton AntiVirus
Nor­ton Inter­net Secu­ri­ty 5.9.1 et ver­sions antérieures
Opswat Gears 10.2.185 et ver­sions antérieures
Par­al­lels 2.5 et ver­sions antérieures
Par­al­lels 7.0.15094 et ver­sions antérieures
Par­al­lels Access 2.0.0 et ver­sions antérieures
Pen Tablet Pref­er­ence 5.3.3–3
Plaxo 1.0 et ver­sions antérieures
Plaxo 3.16.2 et ver­sions antérieures
Plaxo 3.0 et ver­sions antérieures
Print­opia 2.1.10 et ver­sions antérieures
Pro Tools 9.0f121 et ver­sions antérieures
Qmas­ter Components
Qmas­ter Pref­er­ence 3.5 et ver­sions antérieures
QT Desk­top Video Out 1.2.7 et ver­sions antérieures
Quick­Books 2009 10.0f2440 et ver­sions antérieures
Quick­Books 2010 11.0f2972 et ver­sions antérieures
Quick­Books 2011 12.0f5460 et ver­sions antérieures
Quick­Books 2012 13.0.f7630 et ver­sions antérieures
Quick­Books 2013 14.0f10166 et ver­sions antérieures
Quick­Books 2014 15.0f2630 et ver­sions antérieures
Quick­Books 2015 16.0.6 et ver­sions antérieures
Quick­en Essen­tials 1.7.4 et ver­sions antérieures
QQ Input 2.8.999 et ver­sions antérieures
QQ Mac Man­ag­er 2.4.0 et ver­sions antérieures
Rap­port 1.0 et ver­sions antérieures
Rap­port 2.0 et ver­sions antérieures
Raz­er Krak­en Audio Plu­g­in 1.04 et ver­sions antérieures
Raz­er Krak­en 7.1 Audio Plu­g­in 1.02 et ver­sions antérieures
Raz­er Krak­en 7.1 Chro­ma Audio Plu­g­in 1.04 et ver­sions antérieures
Raz­er Krak­en 7.1 Blue Audio Plu­g­in 1.03 et ver­sions antérieures
Raz­er Krak­en 7.1 v2 Audio Plu­g­in 1.1 et ver­sions antérieures
Raz­er Mam­ba 2012 1.07 et ver­sions antérieures
Raz­er ManOWar Audio Plu­g­in 1.2 et ver­sions antérieures
Rub­ber­net 1.2 et ver­sions antérieures
Screen Shar­ing 1.4 et ver­sions antérieures
Sea­gate Max­tor Noti­fi­ca­tionEx­ec 4.1.6 et ver­sions antérieures
Secure­Vault LexarFil­ter 2.2.0 et ver­sions antérieures
Shake 4.10 et ver­sions antérieures
Smith Micro Inter­net Cleanup 5.0.4 et ver­sions antérieures
Smith Micro Inter­net Cleanup 5.1.1 et ver­sions antérieures
SMS Wid­get 3.4 et ver­sions antérieures
Snapz Pro X 4.0.0 et ver­sions antérieures
Sogou IM 2.9.0 et ver­sions antérieures
Son­ner Qio 2.7.1 et ver­sions antérieures
Sophos AntiVirus 7.2.0 et ver­sions antérieures
Sophos AntiVirus 9.4.4 et ver­sions antérieures
Sophos Auto Update 7.3.4 et ver­sions antérieures
Sophos End­point 9.5.2 et ver­sions antérieures
Sophos Home 9.4.4 et ver­sions antérieures
Sound Bun­ny 1.0.1 et ver­sions antérieures
Sound Con­trol 2.2.3 et ver­sions antérieures
Source­Tree 1.5.6 et ver­sions antérieures
Sony Palm 6 Sync Dri­ver 2.0.1 et ver­sions antérieures
SRS iWOW 3.1.x et ver­sions antérieures
SRS iWOW 3.0.x et ver­sions antérieures
Sug­ar­Sync Man­ag­er 1.9.26 et ver­sions antérieures
Suit­case Fusion 17.0.0 et ver­sions antérieures
Sug­ar­Sync 1.0 et ver­sions antérieures
Sug­ar­Sync 1.0.9 et ver­sions antérieures
Switch­er Maestro
Super­Drive Update 2.1 et ver­sions antérieures
Syman­tec End­point Pro­tec­tion 12.1.6565 et ver­sions antérieures
Syn­er­gy KM 1.0.1 et ver­sions antérieures
Sxs Mem­o­ry Card Dri­ver 1.0.45049 et ver­sions antérieures
Tab­Ex­pose 2.3 et ver­sions antérieures
Tell­dus­Cen­ter 2.1.1 et ver­sions antérieures
TorchUp­dat­ed 25.0 et ver­sions antérieures
TotalFind­er 1.6.2 et ver­sions antérieures
Total­Spaces 1.2.9 et ver­sions antérieures
Trans­mit 4.1.7 et ver­sions antérieures
Trend Smart Surf­ing 1.6.1089 et ver­sions antérieures
Trim Enabler 3.2.4 et ver­sions antérieures
Trusteer End­point Pro­tec­tion 1609.22 et ver­sions antérieures
Under­cov­er 5.5 et ver­sions antérieures
Virus­Bar­ri­er 10.6.12 et ver­sions antérieures
Visor 2.2 et ver­sions antérieures
Videobox TAAV­Plu­g­in 2.3T et ver­sions antérieures
Virtru 1.0.2 et ver­sions antérieures
Voda­fone v2.0.6 et ver­sions antérieures
VMWare Fusion 3.1.4 et ver­sions antérieures
VMWare Fusion 4.1.1 et ver­sions antérieures
Wacom 6.3.8–2 et ver­sions antérieures
WD Dri­ve Man­ag­er 2.2.7 et ver­sions antérieures
WD Smart­Ware 2.1.x et ver­sions antérieures
WD Smart­Ware 1.0.x et ver­sions antérieures
WebEx Out­look Plu­g­in 32.5.1 et ver­sions antérieures
XtraFind­er 0.25.4 et ver­sions antérieures
ZEV0 2012.09.23 et ver­sions antérieures

8 Commentaires

LAISSER UN COMMENTAIRE

S'il vous plaît entrez votre commentaire!
S'il vous plaît entrez votre nom ici